Saturday, January 31, 2015

Sigil 0.8.3 Released

This is a big maintenance release. One of the biggest in long time. I highly recommend upgrading because while functionality wise not much has changed a lot of work went into improving stability

Most if not all of the credit goes to Kevin Hendricks (KevinH on MobileRead). He spent a lot of time fixing every memory leak, memory corruption, and crasher he could find. He spent a lot of time really getting Sigil into a state of stability it hasn't seen before.

On top of that Qt 5.4.0 is out which it's own slew of bug fixes. Not as many as we had hoped for but Kevin has tried working around as many of the lingering Qt issues as he could. I can't stress enough how huge Qt 5.4.0 is and how many bug itself has fixed.

Now I also can't leave out Doug Massay (DiapDealer on MobileRead). He's spent a lot of time on the Linux side of Sigil. Which we don't officially support for bug reports... But we do support Linux as a build platform. He wrote a deb and rpm packaging targets to make it easier for distros and user's. Especially for users. This way they can easily build Sigil from source and install / upgrade it using their distro's package manager. This way Linux users can still easily use the latest version of Sigil without having to wait for their distro to release a new version.

For my part I've mostly stayed away from coding. This was the original plan when I took over the project from the very beginning. I do a bit of coding when necessary but my role is project maintainer and leader. Not lead developer like I had been in the past but project manager. Helping contributors and providing support. As well as handling mundane tasks such as releases.

I can say I've very happy with how Sigil is running. I'm doing minimal coding when necessary and mainly helping contributors to understand and learn enough about Sigil so they can contribute. I have done a few things like enhance the plugin framework to allow validation plugins. But otherwise I've mainly been spending my time helping contributors contribute.

I will say one of the big changes with Qt 5.4.0 and why it's now the minimum required version for building Sigil is the fact that they've fixed the macdeployqt application and even integrated code signing directly into it. This means that once again Mac OS X packages are signed with my developer certificate so there shouldn't be any need to disable gatekeeper. The target is 10.9.5 as the minimum OS X version but it was built and tested on 10.10.

Binary packages can be found here. For those curious about what's changed the full change log here.